Jump to content
Sign in to follow this  
m0l0t0v

Dome/interior light not working

Recommended Posts

So my interior light stopped working quite awhile back. I've checked the fuse. Changed it with a spare anyways but still no. It randomly stopped working one day. I've seen things mention about it being because of a new headunit but it happened while I still had the old headunit. Bulbs are also fine. Rear boot works fine from memory. Everything else works fine. What could it be?

Share this post


Link to post
Share on other sites

Have you switched the switch in the middle to On? Does it work then?

 

The switches on the door have been known to fail or clog up and become temperamental 

  • Like 1

Share this post


Link to post
Share on other sites

Switch does nothing. Didn't check the boot light but I'm pretty sure that one does work.

Share this post


Link to post
Share on other sites

Poor electrical connection then, they might have gone rusty

 

Share this post


Link to post
Share on other sites

Is the problem fixed? If so, what was the issue!? Im also having this problem with my mc2 so Im interested in the outcome.

Share this post


Link to post
Share on other sites

My dome light switch was broken which created a bad connection. Switched it for an different one and works gereat again!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×